Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Panorama Community. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Montag, 26. Oktober 2009, 00:37

Tipps zum Optimieren meiner Einstellungen

Guten Tag Community, Ich möchte nun endlich von Pano2VR auf krpano umsteigen. (Vorallem, da mir Pano2VR einfach zu sehr ruckelt) Allerdings frage ich mich, ob man noch bessere Bewegungsqualität hinbekommen könnte als ich in meinen Tests, da mir aufgefallen ist, dass bei mir (und anderen) Die Fullscreen Darstellung fast perfekt flüssig läuft im Browserfenster allerdings immernoch Ruckler zu sehen sind. (Wenn man darauf achtet) Außerdem würde ich eigentlich sehr gerne die Fisheye-Projektion nutzen wofür ich ja mit der Einstellung für "details" auf etwa 16 gehen muss. Das macht die Bewegung ja noch weniger flüssig. mMn bin ich mit der Größe der Würfelflächen schon recht weit runter gegangen (1250x1250 und im Schnitt etwa 250kb groß) Da würde ich eigentlich nicht mehr viel dran machen wollen. Nicht dass ihr mich falsch versteht: Ich bin schon sehr zufrieden aber, da der Fullscreen noch besser läuft frage ich mich ob es irgendwie noch einen Trick gibt. Theoretisch würde ich sagen größere Darstellung = weniger flüssige Darstellung aber bei Vollbildanzeige muss sich das System natürlich nurnoch um das Pano kümmern. Ich denke daran wird es liegen, oder? Über sonstige Tipps zu meiner XML würde ich mich natürlich genauso sehr freuen. (das Ziel ist ja das perfekte Verhältnis Qualität/Bewegung) Entschuldigt bitte die Unordnung mir ist die Reihenfolge der einzelnen Punkte noch nicht wirklich klar und ich wollte erstmal nur, dass alles läuft. Gruß, WALL*E [code] set(plugin[dragmode].visible, false); set(plugin[movemode].visible, true); set(control.mousetype, drag2D); set(cursors.url, %SWFPATH%/skin/drag-cursors.png); set(cursors.type, drag); set(cursors.move, 2|0|30|32); set(cursors.drag, 37|0|30|32); tween(view.fovmax, 155.0, distance(179, 0.25), easeoutquad); tween(view.architectural, 0.0, distance(1.0, 0.25), easeoutquad); tween(view.fisheye, 0.0, distance(1.0, 0.25), easeoutquad, set(view.stereographic,false); ); tween(view.architectural, 0.0, distance(1.0, 0.25), easeoutquad); tween(view.fisheye, 0.0 ,distance(1.0, 0.20), easeoutquad, set(view.stereographic,false); set(view.fovmax,179); tween(view.fisheye, 0.35, distance(1.0, 1.25)); ); tween(view.architectural, 0.0, distance(1.0, 0.25), easeoutquad); tween(view.fisheye, 0.0 ,distance(1.0, 0.10), easeoutquad, set(view.stereographic,true); tween(view.fisheye, 1.0, distance(1.0, 1.25)); tween(view.fovmax, 150, distance(179, 1.25)); ); tween(view.architectural, 0.0, distance(1.0, 0.25), easeoutquad); tween(view.fisheye, 0.0 ,distance(1.0, 0.10), easeoutquad, set(view.stereographic,true); tween(view.fisheye, 1.0, distance(1.0, 0.75)); tween(view.fov, 130, distance(179, 0.75), easeoutquad, set(view.fovmax,150);); tween(view.vlookat, 90, distance(179, 0.75), easeoutquad); ); tween(view.fovmax, 155.0, distance(179, 0.25), easeoutquad); tween(view.architectural, 1.0, distance(1.0, 0.25), easeoutquad); tween(view.fisheye, 0.0, distance(1.0, 0.25), easeoutquad, set(view.stereographic,false); ); [/code]

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »WALL*E« (26. Oktober 2009, 00:51)


2

Montag, 26. Oktober 2009, 06:58

Wieso ein Multires bei 1250er Kacheln und wieso Stillquality=low? Übernimm doch einfach mal die Einstellungen der Beispiele von KRPANO. Da findest du eigentlich alles was du brauchst. Außerdem kannst du im Editmodus die Parameter in deinem Pano in Echtzeit verändern. Da siehst du die Wirkung jeder Änderung sofort.

3

Montag, 26. Oktober 2009, 14:30

Wieso ein Multires bei 1250er Kacheln und wieso Stillquality=low? Übernimm doch einfach mal die Einstellungen der Beispiele von KRPANO. Da findest du eigentlich alles was du brauchst. Außerdem kannst du im Editmodus die Parameter in deinem Pano in Echtzeit verändern. Da siehst du die Wirkung jeder Änderung sofort.
Danke für deine Antwort. Du hast natürlich Recht. Das Multires-Überbleibsel ist natürlich Schwachsinn. Das habe ich übersehen. Bei mir scheint sich es leider irgendwie nicht auf das Pano auszuwirken ob ich LOW oder HIGHSHARP einstelle, das begreife ich noch nicht so ganz. Vielleicht ist die Qualität der Würfelflächen schon zu "LOW". An den Beispielen habe ich mich ja auch orientiert und das Pano so konfiguriert, wie ich es mir eigentlich auch vorstelle. Ich wollte nur wissen, ob ihr speziell zur Bewegung noch irgendwelche Tipps habt. Den Text für das Edit-plugin spare ich mir lieber. Fix das XML neu abspeichern reicht mir, dann kann man auch alt und neu gegenüberstellen. Gruß, WALL*E

4

Montag, 26. Oktober 2009, 14:47

Die xmls sind ja eh frei einsehbar solange nicht encrypt benutzt wurde, da kannst du also ruhig mal stöbern bei anderen Autoren ;)

Bei mir sieht das meist so aus

 <display fps="60" details="30" movequality="LOW" stillquality="HIGH" stilltime="0.250" />

Übrigens meinte ich nicht das Editor Plugin sondern das Options Plugin. Hab ich oben verwechselt, sorry.

 


5

Montag, 26. Oktober 2009, 16:20

Hallo,

manchmal liegts auch einfach nur am eigenen Rechner oder dem Internetzugang. Aus eigener Erfahrung weis ich, dass meine Panos bei mir zuhause einwandfrei laufen, auf anderen Rechnern ist das nicht zwangsläufig so. Ob das nun die Internetanbindung an sich ist, oder der Rechner himself (meine Vermutung) kann ich noch nicht abschließend bewerten.

Hast Du Dein Pano mal auf einem anderen Rechner laufen lassen? evtl. auch lokal, ohne Internet dazwischen?

Gruß
Panoramann





"Ich teile ihre Meinung nicht, aber ich bin bereit, mein Leben dafür einzusetzen, dass Sie sie äußern dürfen" (Voltaire)

www.panoramann.de

6

Montag, 26. Oktober 2009, 17:09

Ich kann nur lokal testen, da ich mangels Vollversion nicht auf meinen FTP-Server hochladen kann. Mit 2.8GHz Dual Core, 4GB RAM und einer GeForce 8800 GS kommt mein Rechner bei den Panos wohl eher nicht an seine Leistungsgrenzen. Aber nochmal: Die Panos laufen schon sehr flüssig (und ich bin anscheinend pingelig was das angeht, denn mit Pano2VR bin ich von der Bewegungsqualität sehr unglücklich) Im Vollbild läuft es dann aber so gut wie perfekt und ich möchte sicherstellen, dass ich "mein Möglichstes getan habe" und es im Browerfenster einfach nicht besser geht. Bis jetzt habe ich aber in jedem Pano von krpano bei dem ich darauf geachtet habe diese Differenz zwischen Vollbild und Fenster. PS: Auf anderen PCs (mit deutlich kleineren Displays) laufen die Panos allerdings komplett ruckelfrei und auch der Unterschied Fenster -> Vollbild ist nicht mehr zu erkennen. Vielleicht liegt es doch an meinem Rechner. Bei 24" kommt da vielleicht irgendetwas in der Software einfach nicht mehr ganz mit. Gruß, WALL*E

7

Montag, 26. Oktober 2009, 23:14

Die xmls sind ja eh frei einsehbar solange nicht encrypt benutzt wurde, da kannst du also ruhig mal stöbern bei anderen Autoren ;)
Kann man sich die XML irgendwie anzeigen lassen auch, wenn nicht das Edit-Plugin eingebunden ist? Das wäre natürlich interessant! Gruß, WALL*E

8

Dienstag, 27. Oktober 2009, 05:33

Sicher geht das. Mußt die nur im Browser aufrufen.

9

Dienstag, 27. Oktober 2009, 15:15

Schon klar, doch dafür müsste ich doch wissen, wo sie liegt und im HTML-Quelltext steht das doch nicht, oder? Gruß, WALL*E

10

Dienstag, 27. Oktober 2009, 15:50

Hi,

doch, steht im html:
z.B.:	so.addVariable("xml", "DATEINAME.xml");

...und im Zweifelsfall: Pano-Autor anmailen und nach xml fragen, ist doch kein Geheimnis.

Gruß
Panoramann



"Ich teile ihre Meinung nicht, aber ich bin bereit, mein Leben dafür einzusetzen, dass Sie sie äußern dürfen" (Voltaire)

www.panoramann.de

11

Mittwoch, 28. Oktober 2009, 11:31

Hi,

für beste Performance würde ich folgendes Empfehlen:
(gilt für die Version 1.0.8)

1. für Panoramen mit:
- aktivierten Fisheye Effect (fisheye > "0.0")
- und/oder sphärischen Panoramen

diese Einstellungen:
- deaktivierter Flash10 Renderer
- movequality auf LOW
- stillquality auf HIGH oder HIGHSHARP
- details je nach Anforderung zwischen 14 und 40 (so niedrig wie möglich, so hoch wie nötig)

die Einstellungen im XML:
<display flash10="off" details="22" movequality="LOW" stillquality="HIGHSHARP" />


2. für Panoramen, bei denen es auf eine perfekte Darstellung und gute Performance ankommt
- Würfelpanoramen verwenden!
- keinen Fisheye Effect (fisheye="0.0")
- Flash10 aktiviert
- movequality10 und stillquality10 beide auf HIGH
(das sind eigentlich die Standard Einstellungen und könnten deshalb auch weggelassen werden)

XML:
<view fisheye="0" />
<display flash10="on" stillquality10="HIGH" movequality10="HIGH" />



zur Fenster/Fullscreen Performance - verwendest du eventuell Safari auf einem Snowleopard Mac?
dort ist läuft Safari standardmäßig als 64bit Programm und hat den 32bit Flashplayer über einen Wrapper eingebunden, welche diesen bzw. dessen Darstellung im Fenster verlangsamt,
das Problem lässt sich lösen, indem man Safari im 32bit Modus startet,
siehe auch:
http://www.macnews.de/news/118560.html

Schöne Grüße,
Klaus

12

Mittwoch, 28. Oktober 2009, 14:12

Danke, sehr interessant! Das werde ich durchtesten. Und ja, Safari auf SL. Die Erklärung scheint einleuchtend. Dann weiß ich zumindest das Safari "schuld" ist. Gruß, WALL*E

13

Mittwoch, 28. Oktober 2009, 19:38

Hi,

...
zur Fenster/Fullscreen Performance - verwendest du eventuell Safari auf einem Snowleopard Mac?
dort ist läuft Safari standardmäßig als 64bit Programm und hat den 32bit Flashplayer über einen Wrapper eingebunden, welche diesen bzw. dessen Darstellung im Fenster verlangsamt,
das Problem lässt sich lösen, indem man Safari im 32bit Modus startet,
siehe auch:
http://www.macnews.de/news/118560.html

Schöne Grüße,
Klaus


Seit ich W7 64bit verwende habe ich auch diese seltsamen Ruckeleien, mein Firefox läuft aber unter 32bit.... hmm.... unter Vista war es einwandfrei und schön geschmeidig...

Gruß Bruno
Freiheit ist auch immer die Freiheit der Andersdenkenden. (Rosa Luxemburg)

14

Mittwoch, 28. Oktober 2009, 22:03

Ahh, wunderprächtig! Danke nochmal Klaus! So müssen die krpano-Panos aussehen, genau wie ich mir das vorgestellt habe! Einsame Spitze! Im 32bit-Modus flutsch alles absolut weich. Ich hoffe darauf, dass bei Apple/Adobe bald etwas passiert, damit auch bei anderen Anwendern die Panos dann flüssig laufen. Besten Dank, WALL*E

15

Donnerstag, 29. Oktober 2009, 14:29

Hallo WALL*E,

auch wenn es bei Dir jetzt funktioniert (Glückwunsch), kann ich noch o.a. Aussagen bekräftigen.
Lasse ich die Panos auf meinem älteren Notebook mit 1,6 GHz (WinXP) laufen, habe ich ebenso ein starkes Ruckeln bei
einer Prozessorlast von 100%. Bei einem anderen Notebook mit Centrino Duo 2,4 GHz (WinXP) verschwindet
das Ruckeln fast vollständig. Die Effekte treten bei mir bei Pano2VR stärker auf, als bei krpano (Multires).
Die Panos sind scheinbar für "schwachbrüstige" Rechner nicht flüssig abspielbar, egal in welcher Fenstergröße.

Gruß
Karsten

machart

Power-User

Beiträge: 106

Wohnort: Ostfriesland

Beruf: Grafikdesigner

  • Nachricht senden

16

Donnerstag, 29. Oktober 2009, 15:06

hi! ich glaub ihr seid alle auf dem falschen pfad... SL ist 64Bit, Safari in SL standardmäßig auch... das flashplugin ist aber 32Bit... musst safari auf 32Bit umstellen, dann ruckelts nicht mehr...
___close to the rainbow___
D300S|D7100|10,5/17-70/70-300|SWFcustom|OSX|APP|KRP
_____panographie.net_____

17

Donnerstag, 29. Oktober 2009, 15:15

hi! ich glaub ihr seid alle auf dem falschen pfad... SL ist 64Bit, Safari in SL standardmäßig auch... das flashplugin ist aber 32Bit... musst safari auf 32Bit umstellen, dann ruckelts nicht mehr...
Ähm, ist doch exakt was Klaus gesagt hat. Hat ja auch super funktioniert. Kartsten hat doch ein anderes Problem. Nämlich, dass sein älteres Notebook einfach nicht leistungsstark genug ist. Gruß, WALL*E

18

Donnerstag, 29. Oktober 2009, 16:23

Die Panos sind scheinbar für "schwachbrüstige" Rechner nicht flüssig abspielbar, egal in welcher Fenstergröße.


Hi, mit diesen Einstellungen:

<display flash10="off" details="14" movequality="LOW" stillquality="HIGHSHARP" />

- Flash10 Renderer ausgeschaltet,
- Details zwischen 12-18
- movequality LOW
- und nicht zu hoher Bildschirmauflösung

sollten die Panos auch auf älteren Rechner noch halbweg flüssig laufen,

ich arbeite noch an einer Art Automatik welche bei geringer Framerate automatisch
'zurückschaltet', allerdings ist das etwas schwierig zu timen...

Schöne Grüße,
Klaus

19

Freitag, 30. Oktober 2009, 08:56

Hallo WALL*E,

auch wenn es bei Dir jetzt funktioniert (Glückwunsch), kann ich noch o.a. Aussagen bekräftigen.
Lasse ich die Panos auf meinem älteren Notebook mit 1,6 GHz (WinXP) laufen, habe ich ebenso ein starkes Ruckeln bei
einer Prozessorlast von 100%. Bei einem anderen Notebook mit Centrino Duo 2,4 GHz (WinXP) verschwindet
das Ruckeln fast vollständig. Die Effekte treten bei mir bei Pano2VR stärker auf, als bei krpano (Multires).
Die Panos sind scheinbar für "schwachbrüstige" Rechner nicht flüssig abspielbar, egal in welcher Fenstergröße.

Gruß
Karsten


Bei mir ist es eher andersrum, auf dem Notebook 2,4 GHz Duo Vista 32bit läuft es flüssig und auf dem PC 2,6 GHz Quad W7 64bit ruckelt's.... an der Leistung allein kann es demnach nicht liegen...

Gruß Bruno
Freiheit ist auch immer die Freiheit der Andersdenkenden. (Rosa Luxemburg)