Sie sind nicht angemeldet.

1

Montag, 18. Januar 2016, 20:27

ausgelagerte xml klappt nicht

Hallo
Ich wollte meine Tour etwas übersichtlicher gestalten. Plan ist es einen Grundriss im Bild zu haben, in dem Hotspots auswählbar sind, und ein Radar mitdreht. Zunächst habe ich das vergrößern und verkleinern des Grundrisses programmiert.

Habe ich den Code in der tour.xml drin, funktiniert alles. Jedoch wollte ich eben der Übersicht willen auslagern in eine eigene map.xml. Nur hier klappt es trotz identischem Code nicht mehr. Ich bekomme die xml parsing failed Fehlermeldung. Anfangs war der Code in der map.xml bei den anderen plugin-Aufrufen
Wo liegt der Fehler?

Zitat

<krpano version="1.18" title="Virtual Tour" onstart="startup();">

<include url="skin/vtourskin.xml" />
<include url="plugins/showtext.xml" />
<include url="plugins/map.xml" />


<plugin name="editor" url="plugins/editor.swf" align="top" x="100" y="100" />
<plugin name="options" url="plugins/options.swf" keep="true"/>
<plugin name="mittendot" url="plugins/dot.png" align="left" keep="true" />
<plugin name="logo" url="skin/logo.png" align="topleft" keep="true" />




<plugin name="speisekarte" url="skin/speisekarte.jpg" keep="true" visible="false" align="center" onhover="showtext(schließen)" onclick="set(plugin[speisekarte].visible, false)" />


<!-- set skin settings: bingmaps? gyro? thumbnails? tooltips? -->
<skin_settings maps="false"
maps_type="bing"
maps_bing_api_key=""
maps_zoombuttons="false"
gyro="true"
title="true"
thumbs="true"
thumbs_width="120" thumbs_height="80" thumbs_padding="10" thumbs_crop="0|40|240|160"
thumbs_opened="false"
thumbs_text="false"
thumbs_dragging="true"
thumbs_onhoverscrolling="false"
thumbs_scrollbuttons="false"
thumbs_scrollindicator="false"
thumbs_loop="false"
tooltips_thumbs="false"
tooltips_hotspots="false"
tooltips_mapspots="false"
loadscene_flags="MERGE"
loadscene_blend="BLEND(0.5)"
controlbar_offset="20"
/>

<!-- set optional skin logo url -->
<layer name="skin_logo" url="" scale="0.25" opened_onclick="openurl('...',_blank);" />


<action name="startup">
if(startscene === null, copy(startscene,scene[0].name));
loadscene(get(startscene), null, MERGE);
</action>


<!-- place your scene hotspots here -->


HIER DIE GANZEN PANORAMEN RAUSGEKÜRZT


</krpano>

Zitat

<krpano>


<plugin name="grundrissbild" url="grundriss.gif" keep="true" align="rightbottom" zorder="5" />
<plugin name="verkleinern" url="verkl.png" keep="true" visivle="true" align="rightbottom" y="263" x="464"
onhover="showtext(Grundriss verkleinern)" zorder="10"
onclick="set(plugin[grundrissbild].scale,0.5); set(plugin[verkleinern].visible, false); set(plugin[vergroesern].visible, true)" />
<plugin name="vergroesern" url="vergr.png" keep="true" visible="false" align="rightbottom" y="131" x="232"
onhover="showtext(Grundriss vergrößern)" zorder="10"
onclick="set(plugin[grundrissbild].scale, 1); set(plugin[verkleinern].visible, true); set(plugin[vergroesern].visible, false)" />




</krpano>

toosten

Fortgeschrittener

Beiträge: 94

Wohnort: Berlin

Beruf: freier Softwareentwickler ( krpano, HTML/JS, PHP, C++, JSP, Java )

  • Nachricht senden

2

Donnerstag, 21. Januar 2016, 08:06

Rufe die XML direkt im FireFox auf, der zeigt wo der XML-Fehler zu finden ist.