Sie sind nicht angemeldet.

Der Flo

Mega-User

  • »Der Flo« ist der Autor dieses Themas

Beiträge: 480

Wohnort: Hamburg

Beruf: Fotograf

  • Nachricht senden

1

Donnerstag, 30. September 2010, 23:55

Flat-Panorama wird nicht angezeigt.

Hallo,

Erste Frage:
ich versuche gerade, Flat Panoramen mit dem "Make Pano Multires Droplet" zu erstellen. Es sieht so aus, als ob alles erstellt wird (Terminal-Teil läuft durch, Ordner mit Tiles und XML ist da), aber wenn ich die HTML öffne, bekomme ich nur ein grau gefärbtes Fenster ohne Fehlermeldung.
Woran kann das liegen??? Irgendwann hatte es schon einmal funktioniert.
Wenn ich aus dem selben Ordner heraus 360-Grad-Sphären mit dem "kmakemultires Droplet" erstelle, funktioniert alles.


Weitere Frage: Wenn ich das Pano auf den "Make Pano Multires Droplet" schmeiße kommt eine Abfrage ob das Panorama Flat oder Sphhäre oder Tonne ist. Kann man, wenn man hier Sphäre eingibt, eine Teilpanorama so Darstellen, dass waagerechte (fluchtende) Linien nicht mehr gekrümmt sind? Wenn ja: Woher weiss ich, wieviel Grad mein Teilpanorama hat (dass wird dann auch abgefragt).

2

Freitag, 1. Oktober 2010, 09:28

Hi,

Zitat

ich versuche gerade, Flat Panoramen mit dem "Make Pano Multires Droplet" zu erstellen. Es sieht so aus, als ob alles erstellt wird (Terminal-Teil läuft durch, Ordner mit Tiles und XML ist da), aber wenn ich die HTML öffne, bekomme ich nur ein grau gefärbtes Fenster ohne Fehlermeldung.
Woran kann das liegen??? Irgendwann hatte es schon einmal funktioniert.
sind die erstellten Tiles auch grau?
das klingt nach einem Fehler mit dem Einlesen/Decodieren des Eingabebildes...
was für eine krpano Tools Version verwendest du?
und was für ein Bild (z.B. TIFF,JPEG,PSB,8/16bit,...) war das?

Zitat

Weitere Frage: Wenn ich das Pano auf den "Make Pano Multires Droplet" schmeiße kommt eine Abfrage ob das Panorama Flat oder Sphhäre oder Tonne ist. Kann man, wenn man hier Sphäre eingibt, eine Teilpanorama so Darstellen, dass waagerechte (fluchtende) Linien nicht mehr gekrümmt sind? Wenn ja: Woher weiss ich, wieviel Grad mein Teilpanorama hat (dass wird dann auch abgefragt).
die horizontale Abdeckung des Panos müsste man irgendwo her wissen, entweder aus dem Stitcher, oder grob schätzen...
es kann auch erstmal irgendein Wert (z.B. 100) eingegeben werden, und dann nachträglich in der XML in dem mit "hfov" Parameter
des <image> Eintrags geändert werden, z.B.
$this->cacheCode('[php]','<image ... hfov="100">')

weiters sollte sich der Horizont des Bildes in der Bildmitte befinden,
sonst wird das Bild verzerrt dargestellt,

der Horizont kann aber auch natürlich per XML in die Bildmitte verschoben werden,
dazu gibt es den "voffset" (=vertikal Offset) Parameter,
ein positiver Wert verschiebt das Bild um die angegeben Grad nach unten, ein negativer nach oben,

am einfach zu Testen auf folgende Art:
zuerst die Limitierung des Sicht auf das Panorama selbst ausschalten:
$this->cacheCode('[php]','<view limitview="off" />')
das ermöglicht es das komplette Panorama mit seiner Ausrichtung im Raum zu betrachten,

dann in der XML versuche die richtigen "hfov" und "voffset" Werte zu finden:
$this->cacheCode('[php]','<image ... hfov="100" voffset="+6">')


wenn man alle Wert eines Panoramabildes lässt sich der voffset Werte aber auch errechnen,

z.B. für ein 240x90 Panorama wo die 90° vertikaler Blickwinkel von -60° (oben) von +30° (unten) reichen:

vfov_von = -60
vfov_bis = +30
voffset = (vfov_von + vfov_bis) / 2 = -15

Schöne Grüße,
Klaus

Der Flo

Mega-User

  • »Der Flo« ist der Autor dieses Themas

Beiträge: 480

Wohnort: Hamburg

Beruf: Fotograf

  • Nachricht senden

3

Freitag, 1. Oktober 2010, 09:48

sind die erstellten Tiles auch grau?
das klingt nach einem Fehler mit dem Einlesen/Decodieren des Eingabebildes...
was für eine krpano Tools Version verwendest du?
und was für ein Bild (z.B. TIFF,JPEG,PSB,8/16bit,...) war das?


-Die Tiles sehen korrekt bunt aus
-ich arbeite mit normalem 8 bit jpg.
-ICh habe keine Ahnung, wie ich wissen kann, welche Datei zu welcher Version gehört. Ich kann Dir aber sagen, was, wenn ich mir die Informationen zu den Dateien (auf MAc) anziegen lasse, als Datum angezeigt wird.DA ich immer alles aus ein und dem selben Ordner heraus entwickle, kann es schon sein, dass da noch veraltete Dateien bei sind.

Konkret liegen u.a. folgende Dateien im Ordner: krpanotools.license von April 2008 (?), Krpano.license von August08, krpano.swf von März 2010, eine krpanotools.swf habe ich gar nicht keine Ahnung ob die fehlt oder ob es sowas nicht gibt, das "make pano (multires)droplet" scheint von März 10 zu sein, dass kmakemultires-Droplet (das einzige das funktioniert von Oktober 08.

4

Freitag, 1. Oktober 2010, 10:52

Hi,

okay, in dem Fall würde ich einfach folgendes empfehlen:
  1. ein neue krpano Tools Paket hier herunterladen - http://krpano.com/download/
  2. in ein NEUES Verzeichnis entpacken! (nicht mit einer anderen Version vermischen!)
  3. die krpano.license und krpanotools.license in dieses Verzeichnis kopieren
  4. jetzt die Droplets von dort verwenden (die Droplets dabei aber nicht aus dem Verzeichnis ziehen! wenn dann Verknüpfung/Aliases davon erstellen, diese können dann auch verschoben werden)

Schöne Grüße,
Klaus

Der Flo

Mega-User

  • »Der Flo« ist der Autor dieses Themas

Beiträge: 480

Wohnort: Hamburg

Beruf: Fotograf

  • Nachricht senden

5

Freitag, 1. Oktober 2010, 13:19

Funktioniert jetzt. Danke